Emby - WHMCS

Viewed 49

Hello, I recently bought both WHMCS system, and as well the Emby WHMCS module.

Latest version of WHMCS 8.8
Running on PHP 8.1

And the puqEmby latest version for php 8.1.

After upload, and with ioncube loader 8.1 installed as well otherwise my WHMCS woulf not work, I get the error:

[Mon Dec 25 22:27:44.484601 2023] [proxy_fcgi:error] [pid 2785223:tid 140174310766336] [client XX.XX.XX.XX:0] AH01071: Got error 'PHP message: [WHMCS Application] ERROR: TypeError: call_user_func(): Argument #1 ($callback) must be a valid callback, function "puqEmby_config" not found or invalid function name in /home/domain.com/public_html/admin/configaddonmods.php:0 Stack trace: #0 {main} {"exception":"[object] (TypeError(code: 0): call_user_func(): Argument #1 ($callback) must be a valid callback, function \\"puqEmby_config\\" not found or invalid function name at /home/domain.com/public_html/admin/configaddonmods.php:0)"} []', referer: https://domain.com/admin/configproducts.php?nocache=XXXX
1 Answers

Good day. We need to upgrade the ionCube Loader to version 12. You can do this safely as the ionCube Loader is compatible with lower versions. For more specific assistance, please provide screenshots of errors from the WHMCS web interface.